Agent: BBSのポート番号を変更する方法(Windows)
問題
環境内のサーバーまたはワークステーションに Barracuda Backup Agent をインストールすると、次のエラーが発生します。
Barracuda Backup Agent setup received error "112 Service Error" while attempting to start service.
原因
選択したシステムでポート5120を使用しているソフトウェアが実行されている可能性があり、それが競合を引き起こし、エラーを生成している可能性があります。
解決
データソース上でポート5120が他のソフトウェアによって使用されている場合、Barracuda NetworksはBarracuda Backup Agentをポート5121を使用するように設定することを推奨します。
ステップ1. システムで使用されているポートを確認する
ポートを設定するために、以下の手順を実行します。
エラーが発生したシステムにログインし、ウェブブラウザを起動します。
Microsoft TechNetサイトのダウンロードページに移動し、TCPViewをダウンロードしてインストールします。
TCPViewを起動します。システムが現在使用しているポートがウェブインターフェースに表示されます。
リストを確認します。ポート5120が使用されている場合は、ステップ2で説明されているようにconfig.iniファイル内のポート番号を変更します。
ステップ2. config.iniに代替ポート番号を追加する
config.iniファイルを通じてポート番号を変更するために、以下の手順を実行します。
エラーが発生したシステムで、config.iniファイルを見つけます。通常、C:\Program Files\Barracuda\Barracuda Backup Agent\configフォルダーにあります。
Notepadなどのテキストエディタでconfig.iniを開き、[configuration]オプションの下に次の行を追加します。例えば:
[configuration]
port=5121ファイルを保存して閉じます。
ステップ3. サービスを再起動する
システムに再度ログインします。
Barracuda Backup Agentサービスを再起動します。
ステップ4. データソースを更新する
Barracuda Backupにログインし、左ペインで関連するBarracuda Backup Serverを選択し、バックアップ > ソースのページに移動します。
右ペインで、エラーが発生したシステムの右側にある「編集」をクリックします。
コンピュータ名フィールドに、上記のステップ2で追加したポート番号を付加したIPアドレスを追加します。 例えば、IPアドレスが「192.168.0.1」で、config.iniファイルに「port=5121」という行を追加した場合、コンピュータ名フィールドを次のように更新します: