Barracuda Backupエージェントのポート番号を変更する

Barracuda Backupエージェントのポート番号を変更する

この記事では、バラクーダバックアップファームウェアバージョン5.0以降を指します。 この記事では、112 Service Error の解決方法を説明します。

問題


ご使用の環境内のサーバーやワークステーション上に Barracuda Backupエージェントをインストールすると、次のエラーが発生します。

Barracuda Backup Agent setup received error "112 Service Error" while attempting to start service.

原因


この場合、システム上で動作しているソフトウェアが 5120番ポートを使用しているため競合が発生し、エラーが発生しています。

解決策


5120番ポートが、バックアップソース上の別のソフトウェアによって既に使用されている場合、弊社では、5121番ポートを使用するように Barracuda Backupエージェントを設定変更いただくようお勧めしています。

ステップ1:システムで使用するポートを決定します

ポート番号を変更するには、次の手順を実行します。

  1. エラーとなったバックアップソールにログインし、DOSプロンプトを起動します。
  2. netstat -an コマンドを実行します。
  3. 現在使用しているポートがリスト表示されます。
  4.  5120番ポートが利用中と確認できた場合、ステップ2に進みます。

ステップ2:代替ポート番号bbconfig.iniを追加します

bbconfig.iniファイルを使用してポート番号を変更するには、次の手順を実行します。

  1. エージェントのインストールディレクトリ、(デフォルト C:\Program Files\Barracuda\Barracuda Backup Agent\config)から bbconfig.iniファイルを見つけます。
  2. メモ帳で bbconfig.iniを開いて、[configuration]オプションの下に port='port number'追加ます。 例えば: 
     

    [configuration] 
    nodeGuide={XXXXXXXX-XXXXXXXX-XXXXXXXX-XXXXXXXX}
    port=5121


  3. ファイルを保存して閉じます。

ステップ3:サービスの再開

  1. 「スタート」>「コントロール パネル」>「管理ツール」>「サービス」にアクセスします。 
  2. 「Barracuda Backup Agent」サービスを再起動します。

ステップ4:アップデートデータソース

  1. ポート番号を変更したバックアップソースを BBSに登録するには、Cloud Controにアクセスし、「BACKUP」>「ソース」を選択。
  2. エラーが発生したシステムの右側にある「編集」をクリックします。
  3. 「コンピュータ名」のフィールドに、上記のステップ2で追加したポート番号とIPアドレスを追加します。
    たとえば、IPアドレスが「192.168.0.1」の場合、「192.168.0.1:5121」と記入し、フィールドを更新します。