Agent : Invalid UTF-16と表示されてバックアップできないファイルがある

BBSは Windows、Linux、Macで利用されているメジャーな文字コードをサポートしています。

ここにある UTF-16もサポートしている文字コードの1つです。

 

症状:

バックアップレポートで以下のような「INVALID UTF-16」と表示されてバックアップできなかったとエラー報告されるファイルが記録される場合があります。

原因:

これは、Windows Server 2016 環境、および Windows Server 2019 環境において、%Systemroot%\System32\LogFiles\Sum フォルダ内へ WindowsOSが標準で出力するログファイル名に稀にUnicode(UTF-16)でエンコードできないファイルが生成される問題に起因しています。このファイルはエクスプローラ上でも文字化けしたファイルとして表示されます。この文字化けしたファイル名が、UTF-16でエンコードできない場合に本事象が発生します。

https://docs.microsoft.com/en-us/archive/blogs/askcorejp/garbled-files-in-sum-folder

対処方法:

Windowsで不具合修正が解決すればよいのですが、その間以下の対応をご検討ください。

  • %Systemroot%\System32\LogFiles\Sum フォルダをバックアップの選択肢から外す。

  • UTF-16でのエラーは、Microsoftのログの問題です。その場合は、ユーザアクセスログ(UAL)サービスを無効にし、UALディレクトリにあるファイルを削除すると、このエラーが発生するインスタンスの数を停止または削減できる場合があります。